use strict;
my $str = 'That\'s
a-
tasty
tic-tac.
Or
-not?';
my $regex = qr/\b([-'])\b|(?!\n)[\W_]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";