const regex = new RegExp('\\b([-\\'])\\b|(?!\\n)[\\W_]', 'gm')
const str = `That's
a-
tasty
tic-tac.
Or
-not?`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);