import re
regex = re.compile(r"\b([-'])\b|(?!\n)[\W_]", flags=re.MULTILINE)
test_str = ("That's\n"
"a-\n"
"tasty\n"
"tic-tac.\n"
"Or\n"
"-not?")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)