using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?<key>[^""]+)_(?<index>\d)"": ""?(?<value>[^""]+)(?:""|,)+\s";
string input = @"[
{
""Kemail"": ""johan@test.nl"",
""KLVorname"": ""Johan"",
""KNachname"": ""Test"",
""KLFirma"": ""Company 123"",
""KLStrasse"": ""Kalverstraat"",
""PosAnz"": ""1058DC"",
""KTelefon"": ""+31610101010"",
""VID"": ""123456789"",
""ArtikelEPreis_1"": 853,93,
""ArtikelEPreis_2"": ""70,64"",
""Artikelname_1"": ""LED Mirror Portau"",
""Artikelname_2"": ""Spaanplaat ruw"",
""ArtikelMenge_1"": ""1"",
""ArtikelMenge_2"": ""3""
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}