use strict;
my $str = '[
{
"Kemail": "johan@test.nl",
"KLVorname": "Johan",
"KNachname": "Test",
"KLFirma": "Company 123",
"KLStrasse": "Kalverstraat",
"PosAnz": "1058DC",
"KTelefon": "+31610101010",
"VID": "123456789",
"ArtikelEPreis_1": 853,93,
"ArtikelEPreis_2": "70,64",
"Artikelname_1": "LED Mirror Portau",
"Artikelname_2": "Spaanplaat ruw",
"ArtikelMenge_1": "1",
"ArtikelMenge_2": "3"
}
]';
my $regex = qr/"(?<key>[^"]+)_(?<index>\d)": "?(?<value>[^"]+)(?:"|,)+\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}