package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?<key>[^"]+)_(?<index>\d)": "?(?<value>[^"]+)(?:"|,)+\s`)
var str = `[
{
"Kemail": "johan@test.nl",
"KLVorname": "Johan",
"KNachname": "Test",
"KLFirma": "Company 123",
"KLStrasse": "Kalverstraat",
"PosAnz": "1058DC",
"KTelefon": "+31610101010",
"VID": "123456789",
"ArtikelEPreis_1": 853,93,
"ArtikelEPreis_2": "70,64",
"Artikelname_1": "LED Mirror Portau",
"Artikelname_2": "Spaanplaat ruw",
"ArtikelMenge_1": "1",
"ArtikelMenge_2": "3"
}
]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}