import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?<key>[^\"]+)_(?<index>\\d)\": \"?(?<value>[^\"]+)(?:\"|,)+\\s";
final String string = "[\n"
+ " {\n"
+ " \"Kemail\": \"johan@test.nl\",\n"
+ " \"KLVorname\": \"Johan\",\n"
+ " \"KNachname\": \"Test\",\n"
+ " \"KLFirma\": \"Company 123\",\n"
+ " \"KLStrasse\": \"Kalverstraat\",\n"
+ " \"PosAnz\": \"1058DC\",\n"
+ " \"KTelefon\": \"+31610101010\",\n"
+ " \"VID\": \"123456789\",\n"
+ " \"ArtikelEPreis_1\": 853,93,\n"
+ " \"ArtikelEPreis_2\": \"70,64\",\n"
+ " \"Artikelname_1\": \"LED Mirror Portau\",\n"
+ " \"Artikelname_2\": \"Spaanplaat ruw\",\n"
+ " \"ArtikelMenge_1\": \"1\",\n"
+ " \"ArtikelMenge_2\": \"3\"\n"
+ " }\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}