# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(?<key>[^\"]+)_(?<index>\d)\": \"?(?<value>[^\"]+)(?:\"|,)+\s"
test_str = ("[\n"
" {\n"
" \"Kemail\": \"johan@test.nl\",\n"
" \"KLVorname\": \"Johan\",\n"
" \"KNachname\": \"Test\",\n"
" \"KLFirma\": \"Company 123\",\n"
" \"KLStrasse\": \"Kalverstraat\",\n"
" \"PosAnz\": \"1058DC\",\n"
" \"KTelefon\": \"+31610101010\",\n"
" \"VID\": \"123456789\",\n"
" \"ArtikelEPreis_1\": 853,93,\n"
" \"ArtikelEPreis_2\": \"70,64\",\n"
" \"Artikelname_1\": \"LED Mirror Portau\",\n"
" \"Artikelname_2\": \"Spaanplaat ruw\",\n"
" \"ArtikelMenge_1\": \"1\",\n"
" \"ArtikelMenge_2\": \"3\"\n"
" }\n"
"]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.