import Foundation
let pattern = #""(?<key>[^"]+)_(?<index>\d)": "?(?<value>[^"]+)(?:"|,)+\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
    {
        "Kemail": "johan@test.nl",
        "KLVorname": "Johan",
        "KNachname": "Test",
        "KLFirma": "Company 123",
        "KLStrasse": "Kalverstraat",
        "PosAnz": "1058DC",
        "KTelefon": "+31610101010",
        "VID": "123456789",
        "ArtikelEPreis_1": 853,93,
        "ArtikelEPreis_2": "70,64",
        "Artikelname_1": "LED Mirror Portau",
        "Artikelname_2": "Spaanplaat ruw",
        "ArtikelMenge_1": "1",
        "ArtikelMenge_2": "3"
    }
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)