const regex = /"(?<key>[^"]+)_(?<index>\d)": "?(?<value>[^"]+)(?:"|,)+\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?<key>[^"]+)_(?<index>\\d)": "?(?<value>[^"]+)(?:"|,)+\\s', 'gm')
const str = `[
{
"Kemail": "johan@test.nl",
"KLVorname": "Johan",
"KNachname": "Test",
"KLFirma": "Company 123",
"KLStrasse": "Kalverstraat",
"PosAnz": "1058DC",
"KTelefon": "+31610101010",
"VID": "123456789",
"ArtikelEPreis_1": 853,93,
"ArtikelEPreis_2": "70,64",
"Artikelname_1": "LED Mirror Portau",
"Artikelname_2": "Spaanplaat ruw",
"ArtikelMenge_1": "1",
"ArtikelMenge_2": "3"
}
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}