// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(?<key>[^"]+)_(?<index>\d)": "?(?<value>[^"]+)(?:"|,)+\s"#).unwrap();
let string = "[
{
\"Kemail\": \"johan@test.nl\",
\"KLVorname\": \"Johan\",
\"KNachname\": \"Test\",
\"KLFirma\": \"Company 123\",
\"KLStrasse\": \"Kalverstraat\",
\"PosAnz\": \"1058DC\",
\"KTelefon\": \"+31610101010\",
\"VID\": \"123456789\",
\"ArtikelEPreis_1\": 853,93,
\"ArtikelEPreis_2\": \"70,64\",
\"Artikelname_1\": \"LED Mirror Portau\",
\"Artikelname_2\": \"Spaanplaat ruw\",
\"ArtikelMenge_1\": \"1\",
\"ArtikelMenge_2\": \"3\"
}
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}