# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![^\/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)/*[local-name()='\1\2']/gx;t' <<< "A/B[boolean(g[@s='2']) = false() and d/f[sds=ds]]/@sd"