use strict;
my $str = 'A/B[boolean(g[@s=\'2\']) = false() and d/f[sds=ds]]/@sd';
my $regex = qr/(?<![^/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)/xp;
my $subst = '*[local-name()=\'\\1\\2\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";