$re = '/(?<![^/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)/x';
$str = 'A/B[boolean(g[@s=\'2\']) = false() and d/f[sds=ds]]/@sd';
$subst = "*[local-name()='\1\2']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;