import Foundation
let pattern = #"""
(?<![^/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"A/B[boolean(g[@s='2']) = false() and d/f[sds=ds]]/@sd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*[local-name()='\1\2']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)