re = /(?<![^\/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)/x
str = 'A/B[boolean(g[@s=\'2\']) = false() and d/f[sds=ds]]/@sd'
subst = '*[local-name()=\'\\1\\2\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result