#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)(?<![^/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)" & @CRLF & _
"|" & @CRLF & _
"(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)"
Local $sString = "A/B[boolean(g[@s='2']) = false() and d/f[sds=ds]]/@sd"
Local $sSubst = "*[local-name()='\1\2']"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)