using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^/\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\d_.:-]*)\()([a-zA-Z][a-zA-Z\d_.:-]*)";
string substitution = @"*[local-name()='\1\2']";
string input = @"A/B[boolean(g[@s='2']) = false() and d/f[sds=ds]]/@sd";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}