const regex = new RegExp('(?<![^/\\[(|=<>!+*-])(?!(?:[a-zA-Z][a-zA-Z\\d_.:-]*)\\()([a-zA-Z][a-zA-Z\\d_.:-]*)
|
(?<=\\s(?!and|or|mod|div))(?!(?:[a-zA-Z][a-zA-Z\\d_.:-]*)\\()([a-zA-Z][a-zA-Z\\d_.:-]*)', 'g')
const str = `A/B[boolean(g[@s='2']) = false() and d/f[sds=ds]]/@sd`;
const subst = `*[local-name()='\1\2']`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);