#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?"
Local $sString = ""ParentID" uuid" & @CRLF & _
""CREATEDA" date NOT NULL" & @CRLF & _
""CREATEDA" date NULL" & @CRLF & _
""CREATEDA" character varying(200) NULL" & @CRLF & _
""CREATEDA" numeric NOT NULL" & @CRLF & _
""CREATEDA" numeric(200,4) NOT NULL" & @CRLF & _
""CreatedA" a NOT NULL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")