package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?`)
var str = `"ParentID" uuid
"CREATEDA" date NOT NULL
"CREATEDA" date NULL
"CREATEDA" character varying(200) NULL
"CREATEDA" numeric NOT NULL
"CREATEDA" numeric(200,4) NOT NULL
"CreatedA" a NOT NULL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}