// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?"#).unwrap();
let string = "\"ParentID\" uuid
\"CREATEDA\" date NOT NULL
\"CREATEDA\" date NULL
\"CREATEDA\" character varying(200) NULL
\"CREATEDA\" numeric NOT NULL
\"CREATEDA\" numeric(200,4) NOT NULL
\"CreatedA\" a NOT NULL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}