const regex = new RegExp('(^\\".*\\") (\\w*) ?(\\w*\\(.*\\))? ?((NOT)|(NULL))? ?((NULL))?', 'mgi')
const str = `"ParentID" uuid
"CREATEDA" date NOT NULL
"CREATEDA" date NULL
"CREATEDA" character varying(200) NULL
"CREATEDA" numeric NOT NULL
"CREATEDA" numeric(200,4) NOT NULL
"CreatedA" a NOT NULL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}