using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\"".*\"") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?";
string input = @"""ParentID"" uuid
""CREATEDA"" date NOT NULL
""CREATEDA"" date NULL
""CREATEDA"" character varying(200) NULL
""CREATEDA"" numeric NOT NULL
""CREATEDA"" numeric(200,4) NOT NULL
""CreatedA"" a NOT NULL";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}