$re = '/(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?/mi';
$str = '"ParentID" uuid
"CREATEDA" date NOT NULL
"CREATEDA" date NULL
"CREATEDA" character varying(200) NULL
"CREATEDA" numeric NOT NULL
"CREATEDA" numeric(200,4) NOT NULL
"CreatedA" a NOT NULL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);