re = /(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?/mi
str = '"ParentID" uuid
"CREATEDA" date NOT NULL
"CREATEDA" date NULL
"CREATEDA" character varying(200) NULL
"CREATEDA" numeric NOT NULL
"CREATEDA" numeric(200,4) NOT NULL
"CreatedA" a NOT NULL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end