use strict;
my $str = '"ParentID" uuid
"CREATEDA" date NOT NULL
"CREATEDA" date NULL
"CREATEDA" character varying(200) NULL
"CREATEDA" numeric NOT NULL
"CREATEDA" numeric(200,4) NOT NULL
"CreatedA" a NOT NULL';
my $regex = qr/(^\".*\") (\w*) ?(\w*\(.*\))? ?((NOT)|(NULL))? ?((NULL))?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}