# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))/\1\2\3\4\5\6/g;t' <<< "I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
"