package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))`)
var str = `I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
`
var substitution = "\1\2\3\4\5\6"
fmt.Println(re.ReplaceAllString(str, substitution))
}