$re = '/(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))/';
$str = 'I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
';
$subst = "\1\2\3\4\5\6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;