#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))"
Local $sString = "I live on 56 something STREET" & @CRLF & _
"I live on 56 something AVENUE" & @CRLF & _
"I live on 56 something BOULEVARD" & @CRLF & _
""
Local $sSubst = "\1\2\3\4\5\6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)