// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))").unwrap();
let string = "I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
";
let substitution = "\\1\\2\\3\\4\\5\\6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}