use strict;
my $str = 'I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
';
my $regex = qr/(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))/p;
my $subst = '\\1\\2\\3\\4\\5\\6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";