# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(\d+) days/\1/g;t' <<< "9 buy property stocks over 4 days"