use strict;
my $str = '9 buy property stocks over 4 days';
my $regex = qr/.*(\d+) days/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";