const regex = /.*(\d+) days/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(\\d+) days', 'g')
const str = `9 buy property stocks over 4 days`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);