import Foundation
let pattern = #".*(\d+) days"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"9 buy property stocks over 4 days"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)