import re
regex = re.compile(r".*(\d+) days")
test_str = "9 buy property stocks over 4 days"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)