re = /.*(\d+) days/
str = '9 buy property stocks over 4 days'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result