$re = '/.*(\d+) days/';
$str = '9 buy property stocks over 4 days';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;