#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+"
Local $sString = "dependencies {" & @CRLF & _
" testImplementation 'junit:junit:4.13'" & @CRLF & _
" api 'org.apache.httpcomponents:httpclient:4.5.5'" & @CRLF & _
" api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'" & @CRLF & _
" api 'adsfadsf'" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")