// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+").unwrap();
let string = "dependencies {
testImplementation 'junit:junit:4.13'
api 'org.apache.httpcomponents:httpclient:4.5.5'
api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'
api 'adsfadsf'
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}