using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+";
string input = @"dependencies {
testImplementation 'junit:junit:4.13'
api 'org.apache.httpcomponents:httpclient:4.5.5'
api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'
api 'adsfadsf'
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}