re = /\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+/m
str = 'dependencies {
testImplementation \'junit:junit:4.13\'
api \'org.apache.httpcomponents:httpclient:4.5.5\'
api \'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2\'
api \'adsfadsf\'
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end