import Foundation
let pattern = #"\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dependencies {
testImplementation 'junit:junit:4.13'
api 'org.apache.httpcomponents:httpclient:4.5.5'
api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'
api 'adsfadsf'
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)