const regex = new RegExp('\\s+(?<type>\\w+)\\s+\\'(?<dep>[A-Za-z0-9-:.]+)\\'+', 'gm')
const str = `dependencies {
testImplementation 'junit:junit:4.13'
api 'org.apache.httpcomponents:httpclient:4.5.5'
api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'
api 'adsfadsf'
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}