package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+`)
var str = `dependencies {
testImplementation 'junit:junit:4.13'
api 'org.apache.httpcomponents:httpclient:4.5.5'
api 'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2'
api 'adsfadsf'
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}