use strict;
my $str = 'dependencies {
testImplementation \'junit:junit:4.13\'
api \'org.apache.httpcomponents:httpclient:4.5.5\'
api \'org.apache.tomcat.embed:tomcat-embed-jasper:9.0.2\'
api \'adsfadsf\'
}';
my $regex = qr/\s+(?<type>\w+)\s+'(?<dep>[A-Za-z0-9-:.]+)'+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}