# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\"[^\"]*\")|[a-zA-Z]+)[,;]/$1,/g;t' <<< "coffee, water; tea
\"coffee, black;\", water; tea"