using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\""[^\""]*\"")|[a-zA-Z]+)[,;]";
string substitution = @"$1,";
string input = @"coffee, water; tea
""coffee, black;"", water; tea";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}